I finally won myself the Random Crap (affectionately known as the Bag of Crap, Bandolier of Carrots, etc.) from during the last Woot-Off!  If that last sentence doesn’t make any sense to you, it’s quite alright, but rest assured that my almost year-long quest to purchase about the most useless thing in the interwebs has come to a close.

A few days later I was greeted a box on my front porch which contained the elusive Bag of Crap.  Below is the unboxing, for anyone that cares.  It’s a little surprising that I care more about this unboxing than I did when I got my MacBook.

The box.  You know it’s good when it says Woot! on the box.

Unopened Box

Opened to see what $3 + $5 shipping buys!

Opened BoxFirst out of the box: 3 x Brothers in Arms Hells Highway Action Figures. Apparently I know so little about video games that I didn’t realize that Brothers in Arms was a video game series.

Brothers in Arms Hells HIghway

FX Adventure Deep Sea Monster handheld game. My brother tried playing it and it reminded me of a little game I bought from Radio Shack when I was a kid.

FX Adventure Handheld Game

Motorola Bluetooth Adapter. Comes with a handy pocket clip so you can carry it around with you.  Or something.

Motorola Bluetooth Adapter

3 x Bacon Salt! This is probably my favorite thing and well worth the $8 spent.  The only thing better would be some Baconnaise.  But the name Bacon Salt just makes me think that it’s something you put on bacon.  As if bacon needs more salt.

Bacon Salt

And finally, a Xyron Carry and Storage Bag.  For carrying around the Personal Cutting System that I don’t own.

Xyron Carry and Storage Bag

All in all, a pretty spectacular Bag of Crap.  On April Fool’s Day they were selling Random Crap again and I almost got another one, but Woot may have a mechanism that prevents a person from getting too much crap too soon.

Computer Fixin'

Take that, Toshiba!

Short Answer:

To reset a BIOS on a Toshiba Satellite A215-S5825 that’s decided develop a password

  1. take off the RAM cover
  2. take out the RAM
  3. peel off the black sticker covering the motherboard
  4. find the solder pads labeled XXX
  5. re-install one stick of RAM in the upper slot
  6. short the solder pads using a small screwdriver or some other implement, scraping off the invisible layer of cruft that may be present over the blobs
  7. while shorting those pads, boot the machine (you may to lay the computer sideways or with the monitor flat)
  8. load the BIOS defaults when prompted
  9. boot into windows and install the latest BIOS
  10. enjoy not having to send your laptop away to Toshiba

Super Long Answer/Anecdote:

So my sister in law has this Toshiba laptop, right, like a Toshiba Satellite A215 (a A215-S5825 actually, but I found that out later), and it decides that it’s going to have a power-on password.  At first I figure that somebody at school got a hold of it and put a password on it, because that’s the only way that a BIOS would suddenly have a password, right?

I try some of the obvious backdoor passwords: BIOS, TOSHIBA, PHOENIX, CMOS…no luck.

Eventually I check Tosbhia’s support site and find this wonderful support bulletin entitled: Incorrect power-on password prompt — with older BIOS versions

A “Password =” prompt may be displayed when the computer is turned on, even though no power-on password has been set. If this happens, there is no password that will satisfy the password request. The computer will be unusable until this problem is resolved.

If the problem has not happened yet, verify that your computer has the BIOS currently available from the Toshiba Support website. See detailed instructions below.

Your computer’s BIOS may already include the fix for this problem, depending upon the model, and when it was manufactured.

This Support Bulletin is not a notice of a new BIOS for your computer; it’s a notice that the password prompt problem has been fixed in relatively new BIOS releases.

The occurrence of this problem on any particular computer is unpredictable — it may never happen, but it could happen any time that the computer is turned on. If this problem does occur, it will be necessary to send the computer to a Toshiba Authorized Service Provider.

Well that’s lovely.

I especially loved the notice that “if this happens, there is no password that will satisfy the password request. The computer will be unusable until this problem is resolved” and “if this problem does occur, it will be necessary to send the computer to a Toshiba Authorized Service Provider.”

And of course, they’ve just published the bulletin because people are probably all suddenly having this problem.

So how to get this resolved without having to resort to sending it away to a Toshiba Authorized Service Provider?  The last time I had to do that was with my Tecra M4 to get the video card or motherboard replaced, and it was a month before I got it back.  This Satellite laptop has a silly BIOS password that will probably take the technicians 10 seconds to fix, and they want me to send it to them?  Bah.

Google returns some ideas.  Removing the battery and/or looking for a reset jumper.  I proceed to take apart the laptop, which I’m not a big fan of doing, only because I’m lazy when it comes to organizing the hundreds of screws that inevitably come out and then when I put it back together I’m missing a screw or one doesn’t fit or something like that.  I’ve been getting better, though.

No jumper, and the battery is soldered on to the motherboard.  I figure I might try shorting the battery to see if it resets.  So I short circuit it for a few seconds and then piece enough of the machine back together so it will boots and try turning it on.  Hurray!  Or so I thought.  The BIOS said something about ‘press F1 to load defaults’ which I did and then rebooted.  And then I saw the password prompt.  Nerds.

More googling showed folks with Toshiba Satellite A105 being able to short some solder pads labeled C88.  Well I’m not working on a A105 but maybe the same thing exists.  At this point the laptop is all but completely torn apart.  And I can’t find a C88 labeled anywhere.  Another site mentions solder pads labeled XXX on the underside near the RAM slots, which you could actually get to without having to take the whole darn thing apart…but of course I didn’t find that out until later.

I tried the XXX solder pads, and nothing good seemed to happen.  It was getting close to the point where I was going to have to break down and send the laptop away, or see if I could con Toshiba support into telling me what to do to reset it.

The next day I tried it again, going back over the same things I’d tried previously in a last-ditch effort.  For the life of me I can’t find a C88 labeled anywhere, and nothing on the top side of the motherboard even remotely seems similar.

Finally, I tried the XXX solder pads again, this time digging into them while I booted the machine.  And there it was. BIOS defaults loaded…reboot…Windows!  Apparently there was some invisible gunk preventing me from getting good connection between the two solder blobs.  I must’ve scraped it off with my repeated attempts.

So then to flash the BIOS.  Just a heads up; I had to burn the CD in order to flash the BIOS because the Windows mode gave me an error and the first time I tried I used the wrong A215 model.  As of this writing, the latest BIOS for the A215-S5825 is v1.80 (available here).

Woot!  No month-long waiting period for Toshiba to ‘repair’ the problem that shouldn’t have occured in the first place.  The laptop is still not completely reassembled, but all appears to be well.

Good luck to anyone else with this problem on their Toshiba.  Maybe this is why I bought a Macbook?  Naaah.

Computer Fixin' Software

Windows Update Stalling/Stuck/Hang at “Searching for Updates”

No time for introductions.

I spent way too much time today trying for get Windows Update to work on a laptop.  When the “Searching for updates” screen would come on, sometimes the progress bar would be empty, other times it would run and run until it failed.

I tried CCleaner and reinstalled the Windows Update Components.  Multiple times.  Still nothing.

C:\Windows\WindowsUpdate.log showed a “SendRequestUsingProxy failed” message.  What?  I’m not using a proxy.

I find bits of Norton around, so I run the Norton Removal Tool.  I also end up removing Trend Micro’s PC-Cillin, thinking that it might be blocking the updates.  No good.

HijackThis doesn’t even show a proxy being set anywhere.  So what’s the deal?

FInally…Google returns this gem of a page:

Advanced Method B

8.    Type the following commands. Press ENTER after each command.

a.     proxycfg -d
b.     net stop wuauserv
c.     net start wuauserv
d.     exit

And there it is. I ran proxycfg all by itself and saw this mysterious IP address for a proxy. showed that it returns to BestBuy…hmm.

So finally: “Installation complete.  You must restart your computer for the updates to take effect.”  On to more important things.