Epicor Tracing Settings

Epicor Tracing. Everbody’s favorite method for figuring out what, where, and when the application does what it does.

For reference, the tracing options are stored locally, per computer in the Mfgsys.exe.config file. It is not stored in the database and is not attached to any particular user.

For those of you that deploy Epicor by just copying binaries, this can potentially lead to problems if you forget to turn off tracing before deploying. Then you wonder why everyone is logging things all the time (at least this is what happened to me).

You’ll note that the XML config files file changes the following values as tracing is enabled:

  • Enable Tracing Logging: DataTrace changes from 0 to 4
  • Exclude client processing from method timing: DisableLegacyTiming changes from 0 to 4
  • Write Full DataSet: DataTraceFullDataSets changes from 0 to 4
  • Track Changes Only: DataTraceFullDataSets changes from 0 to 3
  • Write Call Context DataSet: (unknown, this doesn’t do anything in the config as far as I can tell)

The Mfgsys.exe.config file can be updated manually or via the Tracing Options Form and then deployed to your clients if you need to adjust the tracing settings.

If tracing is completely turned off via the GUI, DataTrace = 0 and DisableLegacyTiming = 4, but I think that you can set both to zero and be okay.

Posted in Epicor | Tagged , , , , | Leave a comment

Upgrading to NConf 1.3.0 on Ubuntu 11.10 Oneiric Ocelot

Congrats to the NConf crew for reaching the 1.3.0 milestone! Two years in the making, but I’m excited to see the project continuing to move forward.

It’s been over a year since I originally installed and configured Nagios and NConf 1.2.6 on my Lucid Lynx server. In the meantime, I’ve upgraded the hardware and moved to Ubuntu 11.10 Oneiric Ocelot, mostly to keep up with the current releases. Not a whole lot has changed for what I use this server for, but keeping up with the Nagios releases in the repos has been convenient.

If you’re following along with this guide but starting fresh with Nagios and Nconf, you’ll probably want to take a look at my previous guide and the NConf installation documentation to get some background information. I’ll try to provide some notes for those of you doing a fresh install, but since I’m just upgrading, I can’t make any promises.

Backups!

Log into your server and make them backups!

sudo cp -rp /var/www/nconf /var/www/nconf.bak
mysqldump -u root -p nconf > ~/nconf_sql.bak

I also backed up my Nagios configs

sudo cp -rp /etc/nagios3 /etc/nagios3.bak

Download and Unpack

Wget or otherwise download the latest version on Nconf. Wget has that issue with following SourceForge links so you may need to rename the file.

Unpack the files and then copy them to where you installed NConf before, or do it all in one step:

sudo tar xzvf nconf-1.3.0-0.tgz -C /var/www

Then fix the permissions for the NConf folder, setting them back to your apache user:

sudo chown -R www-data:www-data /var/www/nconf

Upgrade

Browse to http://<yourserver>/nconf/UPDATE.php

Follow the prompts to proceed with the interactive update. NConf’s documentation on the update process has screenshots that I won’t repost here.

After the upgrade, you’ll need to remove some files and folders. Browse to your NConf folder and nuke them. I also had to remove the call_ajax.php file, which wasn’t in the original documentation.

cd /var/www/nconf
sudo rm -rf INSTALL/ UPDATE/ INSTALL.php UPDATE.php call_ajax.php

There’s been a few changes/additions to the NConf conf file, so open up config/nconf.php and add the following lines:

define('CHECK_UPDATE', 1);
define("DEBUG_GENERATE", 3); # [1=ERROR|2=WARN|3=INFO|4=DEBUG|5=TRACE]
define('CHECK_STATIC_SYNTAX', 1);

Also, set the ALLOW_DEPLOYMENT variable to 1 to enable deploying configs directly from NConf and comment out the other CONF_DEPLOY_ variables, as they aren’t used anymore.

define('ALLOW_DEPLOYMENT', 1);
#define('CONF_DEPLOY_URL', "https://webserver.mydomain.com/incoming_config.php");
#define('CONF_DEPLOY_USER', "deployUser");
#define('CONF_DEPLOY_PWD', "deployPass");

At this point, you should be able to log into NConf 1.3.0 and look around.

Migrating Deployment

With NConf 1.2.6, I used the ADD-ONS/deploy_local.sh script and a cron job to deploy configuration changes to Nagios. In 1.3.0, they’ve integrated this a little better into the core of the application, but it required some adjustment in my setup.

Start off by coping the deployment.ini sample configuration file to the config folder:

sudo cp /var/www/nconf/config.orig/deployment.ini /var/www/nconf/config/deployment.ini

Open up the config/deployment.ini file, uncomment the LOCAL deployment section except for the [copy nagios.cfg] section and change the target_file variables to reference the nagios3 folder where Ubuntu places the config files.

Also, add the reload command (sudo /etc/init.d/nagios3 reload) at the bottom of the [copy global config] section. When you’re done the file will look similar to the following:

;; LOCAL deployment ;;

[extract config]
type = local
source_file = "/var/www/nconf/output/NagiosConfig.tgz"
target_file = "/tmp/"
action = extract

[copy collector config]
type = local
source_file = "/tmp/Default_collector/"
;target_file = "/etc/nagios/Default_collector/"
target_file = "/etc/nagios3/Default_collector/"
action = copy

[copy global config]
type = local
source_file = "/tmp/global/"
;target_file = "/etc/nagios/global/"
target_file = "/etc/nagios3/global/"
action = copy
; *** add the line below
reload_command = "sudo /etc/init.d/nagios3 reload"
; *** keep this section and the rest of the file commented out
;[copy nagios.cfg]
;type = local
;source_file = "/tmp/static_cfg/nagios.cfg"
;target_file = "/etc/nagios/nagios.cfg"
;action = copy
;reload_command = "sudo /etc/rc.d/init.d/nagios reload"

This process replaces the deploy_local.sh script, but we’ll need to allow the web user to issue the Nagios reload. To do that, we need to modify the sudoers file:

sudo visudo

Then add the following lines:

# Allow www-data (apache) user to reload nagios
www-data ALL=NOPASSWD: /etc/init.d/nagios3 reload

Save and quit.

Finally, remove the entry in the root crontab entry that launched the old deploy script:

sudo crontab -e

And remove the line reading:

* * * * * /var/www/nconf/ADD-ONS/deploy_local.sh

Deployment Testing and Cleanup

Let’s make sure the new deployment procedure works. Back in the NConf GUI, click Generate Nagios config. You should hopefully see something like:

[INFO]  Starting generate_config script
[INFO]  Generating global config files
[INFO]  Generating config for Nagios-collector 'Default Nagios'
[INFO]  Ended generate_config script

If the config files generate successfully, you’ll see a button aptly labeled ‘Deploy’.

Click Deploy, and with any luck you’ll be presented with three OK messages in NConf  and your Nagios Event Log should show a SIGHUP message.

Relax, and enjoy some JQuerified NConf 1.3.0 goodness! Gold star!

I did notice that the original deployment method left a bunch of old config tgz bundles, so if you’re feeling like cleaning those up, just remove the whole lot:

sudo rm /var/www/nconf/output/NagiosConfig.tgz.*

Update (6/25/12): You’ll want to remove the extended_host_info.cfg and extended_service_info.cfg files from your target config directory (/etc/nagios3/Default_collector/), or you might get weird problems trying to deploy later on. I just found this out six months later.

Troubleshooting Notes

  • The biggest problems I had were just remembering to reference nagios3 rather than nagios for paths and commands.  Make sure you reference the correct locations. This caused me all sorts of weird grief with the sudoers file, and I didn’t catch it until later.
  • While NConf will run without the additional variables in config/nconf.php, it’ll log warnings until you add them.
  • I had to remove an extra file (call_ajax.php) before NConf would run. The file has been replaced with call_file.php which apparently fixes a security issue. At the time of this writing, removing this file wasn’t in the docs, but it complains until you nuke it.

Fresh Install of Nagios and NConf

From what I can tell, you can follow all the steps in my old guide for installing 1.3.0 up until you get to Configuring NConf to Deploy Nagios Configurations Automatically. At that point, follow the Migrating Deployment instructions from this guide.

Please leave a comment and let me know if you do a fresh install. I’d be curious to know how it works for you.

More Information

 (edit 6/25/12 to add additional file cleanup instructions)

 

Posted in Software, System Administration | Tagged , , , , , , , | 14 Responses

Rain-X Makes Ice and Snow Scraping Easier!

So this was a pleasantly random but surprising find:

Applying Rain-X to your windshield during the fall and winter months will make scraping snow and ice much easier!

Rain-X, for the uninformed, is the mystery window treatment that makes water bead up on the windshield, and will virtually slide up and off the windshield when driving 35+ mph. Apply it during the afternoon during a dry fall or winter day, preferably after cleaning the windshield. Be sure to treat the rear window, your side windows (at least the front ones) and don’t forget the side mirrors.

If you’d like to really see what a difference it makes, don’t treat the back side windows. Then just wait for a frosty morning.

On a related note, buy yourself a Fantastic Ice Scraper. $2 for a great scraper with a brass blade. If you want more info, see the Cool Tools review. Buy them as stocking stuffers for your family!

Posted in Lifehacks | Tagged , , , , , | Leave a comment

Epicor 9 and Vista/Vantage 8 Phone Support Menu Tree

With so many modules to choose from, navigating the Epicor phone support menus can be a daunting task. A full listen through all of the options takes almost 3 minutes!

Here’s a textual representation of the phone trees for my reference and yours. Should be accurate as of October 12, 2011. If I detect a significant change in the menus, I’ll try and update this. A Google search doesn’t return the actual support phone numbers, so I’ll leave those behind EpicWeb, but I’m sure that everyone knows what number they call.

Common Options

  • * (star, asterisk) – return to the main menu from a sub-menu
  • # (pound, hash) – repeat options on the main menu
  • 0 – repeat options on a sub-menu
  • You can also leave a message for support after any of the menus.

Epicor 9

  •  4 – System Down Issue (No users can login into your live environment or completely unable to use the software)
  • 1 – Production Issue
    • 1 – Estimating and Quote Management, Sales Management, Customer Shipping and Receiving, Field Service, Customer Relationship Management, Production Management (including MES (Manufacturing Execution System), Work Management, and Jobs)
    • 2 – Product Data Management (including Bill of Material and Routing), Engineering Changes and Revision Control, Supply Chain Management (including Purchase Management, Quality Assurance, Inventory Management, Advanced Material Management, Vendor Shipping and Receiving, and Warehouse Management)
    • 3 – Advanced Production Modules (including Product Configurator, Scheduling, Advanced Planning and Scheduling, and MRP (Manufacturing Resource Planning))
    • 4 – PLM (Product Lifecycle Management)
    • 5 – IQS or Advanced Quality Modules
  • 2 – Financial Issue
    • 1 – Accounts Receivables (AR) and Accounts Payables (AP)
    • 2 – General Ledger (GL) and Posting Engine, Cost Accounting, WIP Reconciliation, Capture Post Process, and Epicor Payroll
    • 3 – Third-Party Products (including Open4, Payroll, and Human Resources)
  • 3 – Technical Issue
    • 1 – Installation, Upgrades, Performance, Replication, Database, or Admin Console
    • 2 – BPM (Business Process Management), BAM (Business Activity Management), Crystal Reports, or Printing
    • 3 – Demand Management and EDI (Electronic Data Interchange), Win2Web Client, Sonic, Connect, or Pyramid
    • 4 – Tools (including Customization, Personalization, Business Activity Queries (BAQ), Dashboards, or Styles and Themes)
    • 5 – Third-Party Products (including Service Connect, PLM, IQS, Open4, APM (Advanced Print Management), Altec, and others)

Vista/Vantage 8

We’re currently running Vista 8, and technically there’s a separate number listed for Vista versus Vantage users, but the menus sound the same, and from what I can they route to the same people. I always call the Vantage support number.

  • 4 – System Down Issue (No users can login into your live environment or completely unable to use the software)
  • 1 – Production Issue
    • 1 – Sales Processing Modules (including Orders, RMAs, Security, Shipping and Receiving, MES (Manufacturing Execution System), and CRM (Customer Relationship Management))
    • 2 – Production Processing Modules (including Quoting, Engineering and Jobs, Purchasing, Inventory, Quality Assurance, Advanced Inventory Management, and Advanced Material Management)
    • 3 – Advanced Production Modules (including Product Configurator, Scheduling, Advanced Planning and Scheduling, and MRP (Manufacturing Resource Planning))
    • 4 – PLM (Product Lifecycle Management)
    • 5 – IQS or Advanced Quality Modules
  • 2 – Financial Issue
    • 1 – Accounts Receivables (AR), Accounts Payables (AP), General Ledger (GL)
    • 2 – Cost Accounting, WIP Reconciliation, Capture Post Process, and Epicor Payroll
    • 3 – Add-On Modules (including Open4, Payroll and Human Resources)
  • 3 – Technical Issue
    • 1 – Installation, Upgrades, or Database Performance
    • 2 – Crystal Reports or ODBC (support has told me personally that BPM issues should go here as well)
    • 3 – Tools (including Sonic, Customer Connect, Mobile Connect, or Sales Connect)
    • 4 – Customization, Personalization, Dashboards, and Business Activity Queries (BAQ)
    • 5 – Third-Party Products (including Service Connect, CorVu, PLM, FRX, Open4, APM (Advanced Print Management) and others)
Posted in Uncategorized | Leave a comment

vBulletin 4.1.7 Mobile Style Giving You Grief?

I upgraded a forum to vBulletin 4.1.7 last night. Pretty straightforward stuff, only the mobile style that they half-introduced back in 4.1.2 or somewhere along the lines has been a little glitchy.  4.1.6  reintroduced the mobile style, but I blinked and 4.1.7 was released.

I ended up deleting the mobile style and reimporting it from scratch (see Installing the vBulletin Mobile Style from their manual) but the grid menu button didn’t seem to work. The grid menu is where they’ve put notifications, messages, what’s new, etc. in the mobile style. In particular, I had some users ask where the What’s New feature was in the mobile style, and that’s finally been added, so it was important to get the grid menu working.

Here’s what I found.

vBulletin Mobile Style Grid Menu Fix

Set the Default Mobile Style for Modern Browsers to your Mobile style

Under Settings -> Options -> Style & Language Settings, make sure to set the Default Mobile Style for Modern Browsers to your Mobile style. I went ahead and set as the default for Old Mobile Browsers as well, since I don’t know what the difference is.

And voila!

That is all.

Posted in Software, System Administration | Tagged , , , , , , | Leave a comment

Epicor Support Resources

Looking for some help with your Vista/Vantage, Epicor 9 or other related ERP system? There’s lots of information to be had, but it seems to be tucked away in little pockets around the web. Here’s the places I know about, in no particular order:

Application Help

Epicor’s application help can be easily overlooked because it’s sitting right in front of you, but it’s fairly robust. In Vista 8.03, there are cases where some of the documentation refers to deprecated features (possibly from v6), but for the most part the info here is solid. It’s an easy place to start.

EpicWeb

Home of all things Epicor, EpicWeb contains a wealth of information and downloads for the entire line of Epicor products. Download updates, search through active calls, or peruse their knowledgebase of answers. The search function is a little crummy, and it’s not uncommon to get lots of duplicate results. But it’s better than nothing.

One thing to note is that since EpicWeb is a SharePoint site, you can take advantage of the ‘Alert Me’ feature and get email notifications when a file or something else is posted to the site. I use it to let me know when new Epicor 9 files are posted. Pretty handy.

Another important item on EpicWeb is the Epicor Support Management Contact List. It contains escalation contacts, email addresses, and phone numbers, in case you need some additional attention to your issue.

Vista/Vantage and Epicor 9 User Guides

Epicor makes available a number of printed user guides covering the base application, customization and tools. Ask your Customer Account Manager (CAM) and you can order a copy (they’re not free). However, recently they’ve made available electronic copies of the Epicor 9 user guides, freely downloadable from EpicWeb. They’re tucked away under Release 9.05.603, listed as User Guide eBooks. The larger books are broken into chunks. I’d still recommend having at least one printed copy, but the eBooks are great for quick reference or for printing out sections of the user guides to distribute to users.

Similarly, EpicWeb also has a number of technical reference guides for installation, service packs, SDKs, application tuning, etc.

Phone Support or Online Chat

Ah, the good old telephone. I’m sure you’ve all got the numbers handy. There appear to be different numbers depending on what product you’re using, but at least between Vista/Vantage and Epicor 9 there is a little overlap.

I’m a fan of using online chat when I can, since I don’t have to be actively on hold and can be doing other things until I’m at the front of the line, but it feels a little like the same team that fields phone calls also monitors the online chat, so it’s not unusual for an online chat request to time out.

Customer Matrix Viewer (SCR Search)

Software Change Requests (SCR) are an integral part of the Epicor product lifecycle. Bug fixes, enhancements, and other features are assigned an SCR and slated for service packs and patches. Recently, they’ve introduced the ability to search through SCRs through what they call the Customer Matrix Viewer. Neil McLachlan, Vice President of Product Management provides this description of the service:

The purpose of this site is to provide you with Web-based access to a listing of SCRs addressed in previous service packs and patches, as well as SCRs planned for future releases. This will help you plan your upgrades and go-live strategy for Epicor 9 with more insight into your specific requirements, risks, and issue resolutions.

It’s a fairly rudimentary search, but if you’ve been assigned an SCR for a particular issue you’ve been having, it’s a good place to get some info on the status of the fix.

If you need some specific instruction on its use, take a look at the Customer Matrix Viewer How-To Guide.

Epicor’s Vista/Vantage/E9 Users Yahoo! Group

The Epicor Yahoo! Group is my current go-to place for information outside of official Epicor channels. It’s an active community of users asking and answering a wide range of questions. However, I’m not the biggest fan of the mailing list format, and there’s only one big group for everyone to post messages, so it’s easy for your own post to get lost in the mix.

I find it easiest to get the Daily Digest email rather than receive individual emails each time someone posts to the group.

IT Toolbox Epicor Community

I learned about the existence of the IT Toolbox Epicor Community directly from an Epicor employee, who told me that there are at least a few actual Epicor employees that lurk within this community. It’s very similar to the Yahoo! Group, but there is much less monthly activity on the message board on IT Toolbox.

Epicor Users Group 

By the users, for the users. The Epicor Users Group (EUG) maintains a close relationship with Epicor to provide feedback from their members to help make their software better for all of us. It’s a paid membership, but they’re a major sponsor of Perspectives (Epicor’s user conference), and your membership gets you a hefty discount on the entrance fee to the conference. Cost to join is per company, rather than per individual, which is also helpful.

The EUG also has a LISTSERV mailing list available for their members. Their webmaster mentioned to me that they may be moving towards a forum format rather than the mailing list, if that’s more your style. Individual lists are available for a number of different Epicor products, and there are sub-groups for very specific topics. I’m not very familiar at this point with how active the lists are, but it seems fairly lively.

Additionally, this User Group has a unique feature with their Enhancement Request Portal. It allows members to submit enhancement requests that are then reviewed by Epicor when the EUG meets with them, usually on a monthly basis. Other users can amend their thoughts and comments on issues and Epicor also has an avenue to respond directly through the Portal.

Epicor Customer Forums

For the sake of completeness, I’m listing the Epicor Customer Forums, but frankly, it barely gets used. I posted questions there a few times when I first started using Epicor, and got very few responses. I also saw no way to be notified via email when someone responded to my post, which made it cumbersome to use. Not the greatest, but points in my book for being a forum over a mailing list.

Us Doing Stuff

As far as I can tell, Jose Gomez is doing some pretty great stuff, and his Epicor-related blog showcases some of that stuff. Prior to starting this blog, he’s posted some videos to YouTube through the Yahoo! Group and continues to provide useful advice and information. His team now offers maintenance packages at competitive rates, and I’ve spoken to some people that are very satisfied with his services.

Epicor Software – Spiceworks Community

Another very small community can be found within Spiceworks. I use their network monitoring software, so I stumbled across the Epicor group here. There appear to be fewer posts than the barely-used Epicor Customer Forums, so I wouldn’t count on it too heavily, but it’s there.

Progress Communitities – PSDN.com

For Progress/ABL/4GL specific questions, you might check out Progress Communities (PSDN.com). It’s pretty low level stuff and it’s not Epicor-specific, but for the more technically-minded code junkies, this is the place to be.

I should also mention the Progress 4GL Handbook and the Progress 4GL Reference PDFs which are readily available for download. Keep these on hand if you’re looking for more information on ABL/4GL code.

Final Thoughts

Let me know in the comments if there are other useful resources you’ve found in your quest for Epicor knowledge. Consultants and integrators, lets see some practical blogs covering various topics and answering common questions. Epicor, lets keep working towards comprehensive and worthwhile documentation for all aspects of your software. Happy ERPing, everyone!

Posted in Epicor | Tagged , , , , , | Leave a comment

MyFax Support, You Suck

tl;dr MyFax Support sucks. Getting ‘Mydll_NT: Error in function: dAddPortMonitor, Error code: 126.’ installing the Print-to-Fax Assistant? Run msiexec /i myfaxassistantsetup.msi /q and install in silent mode.

Dear j2 Global Communications/Protus/MyFax:

Please remind your company to care about their software and the people that use it. In particular, you need to provide support for the installation of your products. Telling someone you won’t support your own product until it’s installed is ridiculous and asinine.

What Went Wrong: Installing Print-to-Fax Assistant

A few days I attempted to install the MyFax Print-to-Fax Assistant on a fresh-out-of-the-box Dell workstation running Windows 7  Professional 32-bit SP1. Nothing out of the ordinary installed on this system. It’s joined to a domain and I’m running the install as myself, a user with administrative rights on the local machine.

I accept the EULA and all the defaults to get the install on its merry way, and I receive the following error:

MyFax Print-To-Fax Assistant Installation Error

Mydll_NT: Error in function: dAddPortMonitor, Error code: 126.

After that, the install failed and the MSI rolled back.

I tried a reboot and a few other normal troubleshooting tactics, and it all ended with the same error. I’ve got the Print-to-Fax driver installed on a Win 7 64-bit and another Win 7 32-bit install, as well as an XP box, so I know the thing works. Even tried downloading the installer again and comparison the checksum. Everything checked out, but it wouldn’t install. It’s not a particularly helpful error message, and there’s no information on any sort of manual installation process.

To the Googles! Less than 150 results come back on a search for this particular error. Mostly from Black Ice Online Support, which leads me to suspect that they provided the lower level drivers that MyFax uses. Searching for this particular error specific to MyFax returns nothing.

How Not To Help: MyFax Support

MyFax Knowledgebase

Nothing there of any relevance. In fact, it looks like the latest I can find on any subject was last modified almost a year ago in June of 2010. (Update: by the time I got around to finishing this article, I now see one new knowledgebase post from July 2011.)

Online Chat Support

So, it’s time to contact support. First, I try the online chat. Here’s where it gets interesting.

I’m told that:

  • The Print-to-Fax driver is not compatible with Windows 7 (contrary to information on the MyFax site even showing 64-bit Win 7 compatibility)
  • The Print-to-Fax driver is one of the oldest plug-ins they have
  • That Blackberry, iPhone, and Android apps are out or in the making

None of which helps in the slightest to resolve my situation.

It’s also suggested that I turn off my firewall (which it is), and then I’m given a couple of Google hits on the error, neither of which reference MyFax in any way.

Finally, I’m told that it’s not a MyFax error, and it’s the computer that’s giving me this error. Oh really? So the fact that I get this error when installing the MyFax product means nothing? How about uninstalling it and then reinstalling (except I NEVER GOT IT TO INSTALL IN THE FIRST PLACE!!!!!)? Blerg. Kthxbye.

Phone Support

Let’s see if a phone call nets anything more helpful. What follows is a highly paraphrased conversation.

I’m told by the Tier 1 tech that it’s a driver issue, and that I need to install the driver so that the Print-to-Fax assistant will work. And to try Google. Can I speak to a supervisor? Sure, he says, and puts me on hold.

Me: “Hello Mr. Supervisor? I can’t install your program!”

Supervisor: “Well, Mr. Customer, the ‘dAddPortMonitor’ error is a very common error. You need to install the Mydll_NT.dll in order to get our program to work.”

(Common? ‘dAddPortMonitor’ returns less than 300 hits on a search engine. ‘Mydll_NT.dll’ returns about 600)
Me: “I can’t download Mydll_NT.dll, because it came with your software. I can’t install your software.”

Supervisor: “Oh, you can just go to Microsoft.com or Google and search for it and download it.”

Me: “Yeah, no, I can’t.”

Supervisor: “Well we cannot support the Print-to-Fax assistant until it’s installed at which point we can check settings remotely from our systems?”

Me: “So you’re telling me you sell a product that you don’t support? If I can’t get your product installed, I can’t use your product. What about those Blackberry, iPhone, and Android apps? You’re telling me if I can’t get them installed, that’s my own problem?”

Supervisor: “Basically, yes.”

Me: “Okay, we’re getting nowhere. If you have any play at all with anyone in management, customer support, marketing, or product development, tell them that SOMETHING IS MAJORLY WRONG HERE. *click*”

Finally, a Workaround

I really shouldn’t have to do this, and MyFax support has given me nothing to go on, but I keep troubleshooting the issue. Running msiexec.exe with verbose logging options enabled, I discover that the TARGETDIR variable is ignoring the default path and is dumping all the files in the root folder. Changing the path doesn’t help, creating the path ahead of time doesn’t help, nor does copying the extracted files to the path in the middle of the install. Same error.

For kicks, I try a silent install:

msiexec /i myfaxassistantsetup.msi /q

It works. Why? No idea. Do I really care at this point? Not really. I run a test fax through, and it works. Reboot, and it still works.

What’s Still Wrong

So I got the Print-to-Fax Assistant to install. Yay. However, I don’t think I’d be writing all this if the whole support experience wasn’t so terribly, utterly, horribly, bad.

On one hand, MyFax and the whole internet faxing universe is really just an attempt to hold onto an antiquated technology that really should have been replaced by something better years ago, but amazingly, faxing still exists and Osama Bin Laden doesn’t. But that’s beside the point.

Here’s the thing: I pay for your software. Other people pay for your software too.

Granted, it’s not a lot of money every month, but it’s not like I’m mooching off free software. You’ve got a support page with numerous ways to contact you. But to tell me you won’t support me until I get the program installed…that’s just wrong. That’s like Dell telling me they can’t help me troubleshoot a brand new system that won’t boot up until I can get it turned on.

The installation process is a critical part of the distribution of software. If your program can’t be installed, then people can’t use it, and then it’s worthless. Zero stars rating. Refund.

The least you could have done was taken a note of the issue, given me a ticket number, and then ignore me. At least then I would’ve thought (initially) that somebody cared.

What Can Be Done

Start by fixing your Print-to-Fax Assistant installer.

Windows 7 has been out for two years. Make your software compatible. Simple as that. I downloaded the 64-bit version the other day, and got the same error message on my own desktop, and fixed it by running it through a silent install as above. But that’s a poor workaround. I’ve now had this error on at least four separate machines, so it can’t be just a fluke.

Next, figure yourself out as a company.

With all your buyouts, I count at least five distinct faxing services you offer. I’m not going to bother to list them here, and frankly I don’t care about your other products, because I don’t use them. If you want, consolidate all these similar products into one and then focus on making that product better.

Finally, beef up your support.

Support is your first line when customers are having problems. If they can’t resolve simple issues because they’re uninformed of the solutions, then provide training. Make it better.

Maybe you don’t care

j2 Global Communications, it’s entirely possible that MyFax doesn’t matter to you. Somehow your stocks are still are still up and you’ve apparently got money in your pockets with reported growth over a number of years, but the product I care about seems to be dying a slow and painful death. Since buying Protus in December 2010, you cut 100 employees from the Ottowa office and presumably dumped that workload on other locations. On on the MyFax and related websites, I see the following:

  • 1 new knowledgebase article in the last year
  • The last post on the MyFax Blog is from 7 months ago (January 2011) and as far as I can tell, all the actual content contributors on the blog are no longer with Protus or j2
  • A black hole of tweets between Dec 2010 and June 2011
  • Twittermonials on the main page of MyFax.com shows the last favorited tweet to be 200+ days old
  • Last released dates for the iPhone and Blackberry apps are both over a year old, and both with less than 50% ratings. There’s no Android app at all, and no acknowledgement publicly that they’re even working on an app for this platform.
  • The MyFax What’s New page shows a Fall 2010 Update, and nothing newer.

I could be wrong. Maybe you do want to make MyFax better. Maybe you do want to provide customers with a good experience in the bizarre world that merges the zombie-that-will-not-die that is faxing with this internet world that has Google+ and TouchPad fire sales.

People liked MyFax. Unsurprisingly to me, people liked MyFax better than eFax. This should mean something to you when deciding where to devote your time and attention.

If you do care, then show it.

Sincerely,

Jason Navarrete

Posted in Software | Tagged , , , , , , , | 16 Responses

Installing Crystal Reports XI R2 Developer for Epicor 8.03.409

Installing the Crystal Reports Designer is a little bit of a pain. You start with the original, pre-service pack version. Then there’s patches upon patches to install, and Epicor suggests that you install them all–in order–to get up to speed. To confuse things futher, the latest runtimes for Vista/Vantage 8.03.409 is XI R2 .Net 3.0 Runtime SP5 but Epicor 9.04 uses SP6 (6.4, to be exact) and it’s been suggested to me by support to use SP6.4 with Vista. I haven’t experienced any issues running SP6 with 8.03, so that’s fine with me.

EpicWeb has Answerbooks # 11811MPS and 9592MPS with links to all the patches if you want to download them, but installing six patches is a little excessive, in my opinion.

The much more tolerable option is as follows:

  1. Download Crystal Reports XI R2A SP4 Full Build and install using the same key you got from Epicor. Don’t use the installer from your CD.
  2. Download Crystal Reports XI R2A SP6 Incremental Build and install.
  3. Check your version (Help -> About Crystal Reports) and make sure it matches 11.5.12.1838
  4. Be glad you didn’t have to install all those patches.
For what it’s worth, this should probably work on Epicor 9.04, but I’m not running it to know for sure (and frankly, I’m not sure how many people are running 9.04 at all).

More information:

Posted in Crystal Reports, Epicor | Tagged , , , , , | Leave a comment

0x0000007B Stop Error Installing Windows XP? Try Replacing Your CD-ROM Drive

Are you getting the dreaded Blue Screen of Death when you try to install Windows XP?

Have you already tried using a slipstreamed SP3 disk?

Does that error say something like:

STOP: 0x0000007B (0xF78D2524,0xC0000034,0x00000000,0x00000000)
Blah blah blah blah fail blah blah CHKDSK /F blah blah failblog.org

Have you already tried all the different modes of SATA/RAID/AHCI/IDE/Legacy nonsense in the BIOS to try to get your hard drive to be detected properly but the darned thing still doesn’t want to install? Already updated your BIOS to the latest and greatest?

Even tried slipstreaming RAID and/or SATA drivers on an install CD or went so far as to dig up a floppy drive to F6 some drivers in place?

Think there’s no answer?

***Try replacing your IDE CD-ROM/DVD-RW drive with a SATA drive.***

Worked for me.

It’s deceptive, I know, but apparently even though the CD starts the Windows install process and loads drivers and everything seems grand, setup takes a big dump later on. I tried all the options above, even tried an IDE hard drive and SATA raid setups in various combinations, but they all ended in a BSoD. Nothing worked until I swapped the IDE CD-ROM with a SATA CD-ROM drive.

At one when I tried to install Windows 7, I got a message stating: A required CD/DVD device driver is missing. If you have a driver floppy disk, CD, DVD or USB flash drive, please insert it now. Note. If the windows installation media is in the drive, you can safely remove it for this step.

That really should have clued me into the whole CD/DVD thing, but of course I paid no attention, because I assumed if we got that far in the installation, that it was a hard drive controller issue, not a CD-ROM issue. Ah well.

Moral of the story: Try changing your BIOS settings first. Then try changing your CD-ROM drive.

Posted in Computer Fixin' | Tagged , , , | 1 Response

Adding Rails log rotation to Dreamhost (compiling your own logrotate)

(credit goes to Joey Geiger for the original Gist)

Trying to use logrotate to rotate your Rails logs on Dreamhost?   You’ll need to roll your own copy of it.  Fortunately, the process isn’t too bad.  Let’s jump right into it.

SSH to your host and run the following commands (read my notes below if you’re not super gusty):

# create a new cron job (crontab -e) or use panel.dreamhost.com and run it daily
0 0 * * * /home/<your_account>/opt/bin/logrotate -f -s /home/<your_account>/opt/lib/logrotate.status /home/<your_account>/opt/etc/logrotate.conf
cd ~
mkdir -p opt/bin
mkdir opt/lib
mkdir opt/etc
mkdir src
cd src
wget http://www.sfr-fresh.com/unix/privat/logrotate-3.7.9.tar.gz
wget http://www.sfr-fresh.com/linux/misc/popt-1.16.tar.gz
tar xzvf logrotate-3.7.9.tar.gz
tar xzvf popt-1.16.tar.gz
cd popt-1.16
./configure --prefix=/home/<your_account>/opt/
make
make install
cd ../logrotate-3.7.9
# the first make will fail on the final compile (with 'cannot find -lpopt' message)
# some include problem, but this works so i'm not inclined to care too much
make POPT_DIR=/home/<your_account>/opt/include
# this make should complete
make POPT_DIR=/home/<your_account>/opt/lib
cp logrotate ~/opt/bin/
cd ~/opt/etc
vi logrotate.conf
# paste in the logrotate.conf file
/home/<your_account>/<your_website>/shared/log/*.log {
  daily
  missingok
  rotate 7
  compress
  delaycompress
  notifempty
  copytruncate
}


A couple of quick notes here:

    The most substantial difference from jgeiger’s post is the compiling of the popt library, so that in turn, logrotate would compile.  I really don’t know what’s messed up when you try to link to popt (which leads to the compile failing the first time around), but the workaround seems to work just fine.  If someone happens to know what magic flags are necessary to get the compile to work smoothly the first time, please fork the notes and let me know.
    Joe’s Own Editor was the default editor when I tried to edit my crontab, and it makes my brain hurt.  Edit your .bash_profile and add export EDITOR="/usr/bin/vim" to use vim instead. Logout and back in for the change to take effect.

(disclaimer: Don’t break your stuff. Or Dreamhost’s stuff.)

Posted in System Administration | Tagged , , , | Leave a comment